热门关键字:   网站安全  黑客攻防  安全漏洞  系统安全  网络安全

静态路由应用与解析

发布时间:2010-08-19 10:46文章来源:网络文章作者:秩名 点击次数:
摘要:静态路由说明静态路由是指由网络管理员手工配置的路由信息。当网络的拓扑结构或链路的状态发生变化时,网络管理员需要手工去修改路由表中相关的静态路由信息。静态路由信息在缺省情况下是私有的,不会传递给其他的路由器。当然,网管员也可以通过对路由器进...

静态路由说明静态路由是指由网络管理员手工配置的路由信息。当网络的拓扑结构或链路的状态发生变化时,网络管理员需要手工去修改路由表中相关的静态路由信息。静态路由信息在缺省情况下是私有的,不会传递给其他的路由器。当然,网管员也可以通过对路由器进行设置使之成为共享的。静态路由一般适用于比较简单的网络环境,在这样的环境中,网络管理员易于清楚地了解网络的拓扑结构,便于设置正确的路由信息。
在一个支持DDR(dial-on-demand routing)的网络中,拨号链路只在需要时才拨通,因此不能为动态路由信息表提供路由信息的变更情况。在这种情况下,网络也适合使用静态路由。
使用静态路由的另一个好处是网络安全保密性高。动态路由因为需要路由器之间频繁地交换各自的路由表,而对路由表的分析可以揭示网络的拓扑结构和网络地址等信息。因此,网络出于安全方面的考虑也可以采用静态路由。
大型和复杂的网络环境通常不宜采用静态路由。一方面,网络管理员难以全面地了解整个网络的拓扑结构;另一方面,当网络的拓扑结构和链路状态发生变化时,路由器中的静态路由信息需要大范围地调整,这一工作的难度和复杂程度非常高。
静态路由的配置命令(以右图为例)

router(config)#hostname A (更改路由器主机名)
A(config)#interface f0/0 (进入接口f0/0)
A(config-if)#ip address 192.168.1.1 255.255.255.0 (设置接口ip地址和子网掩码)
A(config-if)#no shutdown (启用接口)
A(config)#interface f0/1
A(config-if)#ip address 192.168.2.1 255.255.255.0
A(config-if)#no shutdown
A(config)#ip route 192.168.3.0 255.255.255.0 192.168.2.2 (目标网段ip地址 目标子网掩码 下一路由器接口ip地址)
router(config)#hostname B
B(config)#interface f0/0
B(config-if)#ip address 192.168.3.1 255.255.255.0
B(config-if)#no shutdown
B(config)#interface f0/1
B(config-if)#ip address 192.168.2.2 255.255.255.0
B(config-if)#no shutdown
B(config)#ip route 192.168.1.0 255.255.255.0 192.168.2.1
 

标签分类: 局域网 交换机

上一篇:cisco交换机配置802.1x的相关操作命令
下一篇:防火墙的定义与应用